🎉

【Gatsby + Netlify】「error Plugin gatsby-transformer-sharp returned an error」というエラーの対策

久々にブログを書こうと思いローカルで起動してみたら以下のエラーがでたので対応メモです。

error Plugin gatsby-transformer-sharp returned an error
error Plugin gatsby-plugin-sharp returned an error

試しにpackage-lock.jsonを削除してnpm installしてみた。

次にgatsby developすると、

warning Plugin gatsby-plugin-manifest is not compatible with your gatsby version 2.1.31 - It requires gatsby@^2.4.0

というエラーがでた。

package.jsonをgatsby@^2.4.0に修正し、node_moduleを削除して再度npm installを実行。 無事エラーが消えて無事表示できました。 久々に触ると色々と忘れてて焦りますね。

零細経営6年目|Web・アプリ開発(React Native + Expo + Firebase)|Youtube|米国株投資|ピアノ