📱

【React Native + Expo】iOSシミュレーターを起動すると「Simulator not installed.」とエラーがでた場合の対策

概要

久々に触ってみたら以下のエラーがでた。 React Native単体でも起きてて、Xcode(10.2)の影響らしい。

Simulator not installed. Please visit https://developer.apple.com/xcode/download/ to download Xcode and the iOS simulator. If you already have the latest version of Xcode installed, you may have to run the command `sudo xcode-select -s /Applications/Xcode.app`.

参考

対策

$ open -a Simulator
$ exp ios

これで一応起動できるが毎回やらないといけない。 早く直ってほしい〜。

CEO & Enginner.(PHP/React Native+Expo/Python/Gatsby+Netlify) 起業6年生。WEBとかアプリ開発しております。趣味は読書、米国株長期投資。ほぼ毎日スマブラやってるただのピチュー使いおじさん。